Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 11, 2026 - 00:00 GMT
Scheduled
Due to the issues the other night, and in the early hours today, our backhaul supplier to Team Valley will be performing some emergency maintenance within their core network. This is to ensure a continuous and reliable service, and to avoid such incidents in the future.
Posted Mar 10, 2026 - 21:38 GMT
This scheduled maintenance affected: Interconnects (Ethernet Services), Broadband Services (Fibreconnect Full-Fibre), and Wildcard Local Fibre Network (Gateshead).