Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2026 - 23:00 BST
Scheduled
Service Impact: At Risk Impact Period: Up to 3 Hours
On the 1st, we'll be performing an on-load test with our generator. We don't envisage any issues, however power should be considered at risk for the duration of this maintenance window.
Posted May 19, 2026 - 09:44 BST
This scheduled maintenance affected: Datacentres (Reliance House).