The link is now back online, and we are monitoring closely for any further issues.
Posted Jun 19, 2025 - 02:26 BST
Investigating
We've detected an issue with our Lumen IP transit in our Manchester data centre, where our port is hard down. Engineers are engaging their support team to investigate the issue. Traffic has been rerouted around the fault automatically.
Posted Jun 19, 2025 - 02:08 BST
This incident affected: Datacentres (Equinix MA1) and Upstream Internet Connectivity.