Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 07, 2025 - 00:00 GMT
Scheduled
Service Impact: Outage Impact Period: Up to 40 minutes
On the 7th, CityFibre will be performing firmware upgrades for all Fibreconnect customers between 00:00 and 06:00. Customers will experience an outage for 40 minutes during this maintenance window.
If you are experiencing connectivity issues after this maintenance ends, please restart your equipment and reach out to support@fibreconnect.net if issues persist.
Posted Nov 13, 2025 - 16:32 GMT
This scheduled maintenance affected: Broadband Services (Fibreconnect Full-Fibre).