Incident: Arcot Grange FTTP Outage

Incident Report for Wildcard Networks

Resolved

This incident has been resolved.
Posted Mar 01, 2026 - 13:44 GMT

Monitoring

Power has been restored - We'll monitor for stability over the next 24h
Posted Mar 01, 2026 - 05:53 GMT

Identified

We have identified loss of power to our network equipment
Posted Mar 01, 2026 - 01:52 GMT

Investigating

Impact Period: Ongoing
Service Impact: Outage

We are aware FTTP customers at Arcot Grange have lost connectivity again today - Engineers are once again working on this incident.
Posted Mar 01, 2026 - 00:33 GMT
This incident affected: Broadband Services (Fibreconnect Full-Fibre).