Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 03, 2025 - 00:00 BST
Scheduled
Service Impact: Outage Impact Period: Up to 6 hours.
CityFibre will be performing maintenance on their network hardware serving parts of the North Tyneside area. Some customers may experience an outage between 00:00 - 06:00 on August 3rd.
We apologize for any inconvenience this may cause.
Posted Jul 02, 2025 - 12:05 BST
This scheduled maintenance affected: Broadband Services (Fibreconnect Full-Fibre).